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Lesson 1. New project 
                 Vectorizing of black objects

Step 1. Project creation

It is senseless to vectorize an image ignoring the target GIS. Suppose, it's ArcGIS and the 
map image is already georeferenced and enclosed in a vector frame. 
Let us import the map's vector frame from ArcGIS into Easy Trace. As it should be 
placed somewhere to, Easy Trace automatically generates a new project.

1.	Invoke Easy Trace.  
Select Import from File menu. 

2.	Select SHP format and specify the 
folder, which contains the SHP-file 
of vector frame. 
In this case it is: 
D:\Lessons\Example\SHP Frame

3.	Specify new project parameters: 
name Lesson_1 and folder D:\
Lessons. This directory will contain 
a subdirectory of the project.

4.	The image in our example is a scan 
of topographic map. Map scale is 
1:200000. Coordinate units of the 
map - meters. 
 
Input these parameters and specify 
additionally resolution of the image 
- 500 DPI. 

5.	Click Next to open the dialog box 
where layers may be selected for 
import.
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6.	The SHP-file we need is already 
marked. Click Next to open the next 
dialog box.

7.	Select the Without coordinate 
transformation option.

8.	Parameter input is over. Click 
Finish.

9.	Check accuracy of chosen import 
parameters.  
Click Back if they require 
correction.

10.	Click Start to import data.

11.	Review information window of the 
Import utility and click Close. 
Lesson_1 project is created.

The project was automatically generated at import of the vector frame.

Project boundaries were calculated from the frame extent.
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1.	Select Add Image in Project menu. 

2.	Select the image in the Linking 
Image dialog box:
D:\..\Example\Raster\Base.jpg

3.	Select linking method -  
based on an external reference file.

4.	Click Next.

5.	Select the registration file for 
Base.jpg image: 
D:\..\Example\Raster\Base.jgw. 
Click Open.

6.	Switch on the option Copy image 
into project folder. 
Easy Trace will use a copy of the 
source image.  
It is convenient for project delivery 
to operators and protects the initial 
image from accidental alterations.

7.	Click Finish. 
The Base.jpg image is copied to the 
folder of project's rasters and linked 
to the vector field.

Step 2. Raster adding to project

We have already imported the vector frame encompassing the area of future vectorizing. 
Now we shall add the image itself applying a TFW-file of raster registration. The file will 
be taken from ArcGIS as well. 
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Step 3. Extraction of the black subject layer

Black-and-white images only are suitable for effective automatic vectorizing. Forming of 
such images out of the initial color one we call Extraction of subject layers. 

There is a ceratin succession of raster operations for extraction of every subject layer. 
Main tools to be used are Diffuse, Unsharp Mask, and Subject Layer Extraction  .

The latter tool exploits the fact that different colors dominate in lines of different subject 
layers. It is reasonable usually to extract the black, red, blue, and green layers.

Main complexity of the process is connected with absence of solid colors both on the 
paper and in the raster. Every color is represented by numerous tints.

Let us hide the image outside the vector frame around the area of vectorizing. This option 
is useful for correct represenation of mosaic raster field made of several nonrectangular 
map sheets.

1.	Select Crop / Clip from Rasters 
menu.

2.	Select Polygonal option.

3.	Keep the Ctrl key pressed and click 
the vector frame of the map sheet.

4.	Click the mouse right button and 
select Set clipping  from the 
contextual menu 
 .
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1.	Press Ctrl+L to open Layer Manager.

2.	We are going to extract black-and-
white subject layers from the Base.jpg 
image. But JPG format does not allow 
saving of binary rasters. That's why 
we shall save Base.jpg as Base.tif.  
 
Click the mouse right button on the 
Base.jpg layer name and select Save 
Image as TIFF option.

3.	Let us make a copy of Base.tif and 
change it into the «Black» black-and-
white image by means of successive 
modifications. 
 
Click the mouse right button on 
the Base.jpg layer name and select 
Duplicate Layer option.

4.	Type Black as the new raster layer's 
name and click ОК.

5.	Select Open Image for Editing option 
from Rasters menu.
Specify Black.tif.

6.	Pixels of «black» lines are of different 
tints in fact. 
We shall average the color with the 
help of Diffuse Tool  .
  
Specify operation parameters: 
Factor = 1,5 
Radius = 2 pixels 

7.	 Unsharp Mask   now to increase 
contrast of lines.   
 

6



6

Specify operation parameters: 
Factor = 500% 
Radius = 3 pixels 
Threshold = 0

8.	Now we want to substitute all bright 
and distinctly non-grey colors for 
white. 
 
Select Subject Layer Extraction .
Specify operation parameters as it is 
shown in the figure. 
  
Create a new strategy  to save 
these settings of the tool, call it
Grey-Based Filtering and click .
 

9.	Diffuse  again to delete white 
pixels in black lines and small 
''rubbish'' on the white background.  
 
Specify operation parameters: 
Factor = 1,5 
Radius = 2 pixels. 
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10.	Remnants of diffused small rubbish 
objects and halos around lines 
should be deleted. 
 
Select Subject Layer Extraction .
Specify operation parameters as it is 
shown in the figure.
 
Create a new strategy  to save 
these settings of the tool, call it
Brightness-Based Filtering and click 

.
 
 
 
 
 
 

11.	Apply Unsharp Mask  for 
drastic increase of line contrast . 
 
Specify operation parameters: 
Factor = 1000% 
Radius = 9 пкс 
Threshold  = 0

12.	Now we transform the image into 
a black-and-white one (it remained 
TrueColor yet (24 bpp)). 
 
Select Color Mode -> Monochrome 
in Edit menu.
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13.	Easy Trace always vecrorizes 
WHITE lines on BLACK 
background.  
 
Invert the image with 
Inversion tool  .

14.	Press Ctrl+S to save the extracted 
Black.tif.

15.	Close the window of image editing.

The «black» subject layer we have extracted depicts topographic symbols well enough and 
will be used later for automatic object recognition and tracing of dotted lines.

But it is overladen for vectorizing of linear objects. 
As we are going to recognize the coordinate grid, let us prepare one more version of this 
subject layer - a thinned image.

1.	Press Ctrl+L to open Layer Manager 
and duplicate the Black.tif image as 
Black_thin.tif

2.	Select Open Image for Editing in 
Rasters menu. 
Select the Black_thin.tif image

3.	Select Image Thinning command in 
Edit menu to thin («skeletonize») the 
current image.

4.	Press Ctrl+S to save changes in Black_
thin.tif.

5.	Close the window of image editing. 
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Step 4. Image vectorizing.  
              Recognition of grid lines

Grid lines in the image hinder vectorizing badly. They make gaps in lines of color sibject 
layers and complicate tracing of black lines. 

Easy Trace can recognize grid lines automatically. The grid may be used later for exact 
correction of the image in every grid cell and at subsequent extraction of other subject 
layers.

1.	Automatic vectorizing of the Black_
thin.tif image. 
Select Auto Tracing -> Autotrace 
Lines in Utilities menu.

2.	Select the Black_thin.tif raster layer 
for tracing. 
 
Vector lines will be attributed to the 
Auto layer by default. The program 
generates this layer automatically.  

3.	As the «black» image is thinned, it 
is impossible to determine width 
of source raster lines automatically, 
and we must input it manually. 
 
Select Taken equal to given value 
option and specify line width equal 
to 5 pixels.

4.	Click Start.
When tracing is over, close the 
dialog box of Autotrace Lines utility.
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5.	Select Auto Tracing -> Autodetect 
Grid in Utilities menu.

6.	Specify the area of grid recognition.  
Click Area button, then keep the 
Ctrl key pressed while pointing 
the vector frame (attributed to the 
Frame layer) with the cursor. Click 
Area button again to «release» it.

7.	Select the Auto vector layer, which 
contains vector data generated at 
automatic vectorizing of the Black_
thin.tif image.

8.	Specify allowable deviation of grid 
lines from due position (search 
distance for grid segments) equal to 
2 pixels.

9.	Select Move segments to layer option 
and type the name Grid for the new 
vector layer, which will contain 
found grid segments

10.	Switch on the option Replace 
original segments with normalized 
grid.

11.	Click three nodes of one grid cell 
somewhere in the center of the map.

12.	Click Apply and close the dialog 
box.
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1.	Select Rasterize Vector Data 
command from Utilities menu.

2.	Select (tick off) the Grid vector layer, 
which contains grid lines.

3.	Select theBlack.tif raster layer into 
which lines from the Grid layer will 
be inprinted.

4.	Select color for rasterized vector 
objects – black.

5.	Select Use fixed width... option and 
specify width of rasterized polylines
 - 7 pixels.

6.	Click Start.

7.	If grid lines are completely deleted 
from the image, close the dialog box. 
Otherwise apply Undo and increase 
the width of rasterized polylines.

Step 5. Grid line deletion from the Black image

Ideally, vectorizing should be INTERRUPTED after vector grid getting (not 
mathematically accurate one but the grid corresponding to coordinate lines IN THE 
IMAGE). Depature of real grid from ideal one is often too big - several times more than 
line width

So, it is reasonable to georeference the image again applying information about due 
position of every grid node. Easy Trace has a special Relink Image command for this 
purpose illustrated by video. 

But we shall skip the operation and continue. The grid will be used to facilitate 
vectorizing of other raster objects.
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1.	Select Auto Tracing -> Outline 
Contours in Utilities menu.

2.	Specify outlining parameters as it is 
shown in the figure: 
  
- outline spots of raster layer Black.
tif. 
- create polylines on vector layer 
Outlines_auto. 
 
Skipping parameters exclude 
small spots and thin lines from 
vectorizing. 

3.	Select Only without holes in the 
field Save the following contours to 
exclude objects without continuous 
filling from vectorizing.

4.	Click Start.

Step 6. Automatic recognition of orthogonal objects

There may be thousands of black rectangles - blocks in one sheet of a topographic map, 
especially in densely populated areas.  
It is simple enough to vectorize them automatically.

The utility has generated dense vector contours - one polyline vertex per one image pixel. 
Easy Trace applies a series of characteristics to identify orthogonal contours among 
others.

The program has a special utility for recognition of ortho-objects. Its parameters are 
rather numerous, but easily understandable. At that, many parameters may be specified 
by selection of samples just on the screen. 
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5.	Select Auto Tracing -> Autodetect 
Ortho-Objects in Utilities menu.

6.	Specify the layer of source contours 
Outlines_auto and a new layer, 
which will contain results of contour 
recognition - Blocks_auto. 

7.	Switch on Delete original polylines 
option to simplify review of 
recognition results.

8.	Original image line width is equal to 
5 pixels, i.e. to the average width of 
black lines in the color image.

9.	To determine Contour length range, 
select contour samples with the 
Editor. It is from 25 to 38 vertices in 
our example.

10.	We want to recognize rectangles 
only, hence Maximal number of result 
edges is 4.

11.	Let us exclude contours around 
long strokes of thick dashed lines. 
Maximal resulting rectangle edges 
ratio (long side to short one) = 2.6.

12.	 Allowable deviation (of object form 
from rectangularity) = 20% - 
to be chosen by review of samples 
selected with the Editor.
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13.	If we deal with a stipulated 
set of topographic symbols, 
it is reasonable to specify 
standardization patterns for 
rectangular objects.  
 
Click the icon   in the lower left 
corner of the dialog box and specify 
parameters as shown in the figure. 
Click ОК.

Some blocks are basically unfit for automatic recognition. They are cut by grid lines or 
«stuck» to road lines. Thus, the next stage consists in regular review and correction of 
recognition results. 

Apply Inspector for this purpose with parameters shown in the figure. Keys 4 / 5 (next / 
previous frame) enable systematic review of the project. Do not move to the next frame 
before you have corrected all defects in the current one.

Minimal length of resulting edge and Maximal number of adjusted contours are 
parameters provided for complex orthogonal contours in 1:2 000 and 1:500 schemes. 
Maximal non-orthogonal part allows recognition of partly orthogonal objects.

14.	Click Preview to estimate results. 
Alter operation parameters if 
necessary.

15.	Click Apply to recognize ortho-
objects.
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Step 7. Deletion of block contours and grid lines from the thinned 
image Black_thin

1.	Select Rasterize Vector Data 
command from Utilities menu.

2.	Select (tick off) source layers - Grid 
and Blocks_auto.  
The Blocks_auto layer should be 
rasterized as polygonal - click the 
rhomb left of its name.

3.	Specify Black_ thin, as the target 
raster layer, into which objects of the 
layers Blocks_auto and Grid will be 
inprinted.

4.	Select color for rasterized vector 
objects – black.

5.	Select Use fixed width... option and 
specify:
for polylines - 5 pixels, 
for polygons  - 1 pixel.

6.	Click Start.

Use Rectangle tool  to vectorize unrecognized rectangular objects in manual  
mode.

The tool can capture vectorized contours if you point them with the mouse right button 
and copy them at left click. Press Escape to leave copying mode. 

Mouse wheel rotates the captured contour slowly if Shift key is pressed and quickly if you 
press Ctrl.

Deletion of vector «rubbish» and gross distortions of object shape should be done by 
Vector Eraser tool   (Q hot-key). At that, «Red Eraser» is provided for object deletion 
(keep Shift pressed), whereas «Blue Eraser» (Ctrl key pressed) cuts the object up.
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1.	Select Auto Tracing -> Autotrace 
Lines in Utilities menu.

2.	Select the thinned raster layer 
Black_ thin.tif for vectorizing.

3.	Type the name of a new vector 
layer Auto_lines, wich will contain 
generated polylines.

4.	Parameter Do not trace lines thicker 
than is irrelevant to our example 
as the image is thinned and has no 
lines thicker than 2 pixels. 

5.	Average width of traced raster lines 
should be specified manually as it is 
indeterminable in thinned images. 
It is 5 pixels in the example. 

6.	Click Start and close the dialog box.

Step 8. Vectorizing of linear objects

2

5

Automatic tracing forms a set of line fragments that correspond to the source image. The 
lines are «dense» - one vertex per one pixel of the image.

No suppositions about line shape and nature were done at this stage. All joints of three 
and more lines are represented by nodes. 

Such vector data suite well for noise deletion and recognition of vector objects. We 
deliberately refused from all operations with line segments at the stage of automatic 
tracing.
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7.	Delete obvious gaps in lines by 
the first (short-distance) break-up 
joining. Angle of convergense of 
line segments should be close to flat 
one (180º). 
 
Select Auto Tracing -> Breakup 
Joining in Utilities menu.

8.	Specify the layer of lines to be 
mended - Auto_lines. Select Frame 
layer as barrier one.

9.	Specify the radius to search line 
continuation within - 20 pixels.

10.	Allow the program not to consider 
direction of segments shorter than 
3 pixels.

11.	Input 145º for minimal angle 
between segments that will be sewn 
together. 
Line width in the source image may 
be skipped - this value will be taken 
from Autotrace utility.

12.	Click Start.
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«Short-distance» breakup joining has eliminated most accidental defects in lines. The 
defects are usually caused by paper wear and errors of subject layer extraction from 
«overcompressed» images.

It's better not to avoid too big values of radius and small ones - of convergence angle, 
otherwise you may «sew» fragments of vectorized inscriptions and other «rubbish» to 
lines. It will take manual editing to separate them later... 

Next step - vector filtering of long («sewn together») line segments.
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Parameter selection “in the screen” may cause unreasonably large capture of objects. 
Click  button to reset parameters of the specific type and repeat selection of defect 
examples. 

1.	Delete obvious vector «rubbish» 
with the help of vector filtering. 
Select Auto Tracing -> Raw Line 
Filtering in Utilities menu.

2.	Auto_lines remains the source 
vector layer.  
The object is to recognize lines of 
road network. Adjusted parameters 
of this operation are saved in the 
example as Step_1 strategy.It is 
enough to select it.  
 
Branches, Loops, and Strokes are 
defects to be corrected. They form 
small «rubbish» and vectorized 
inscriptions.

3.	Click Preview to estimate quality 
of correction. To select better 
parameters, click the left button on 
examples of defects. 

4.	When parameter selection is over, 
click Apply.

5.	Repeat items 3 and 4 several times 
in a row, until the utility find no 
defects any more.
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6.	Most of «rubbish» objects are 
delited. Probability of false joining 
has abruptly decreased. Fulfil the 
second breakup joining with longer 
radius and weaker restrictions on 
line convergence angle.

7.	Increase search distance up to 30 
pixels and allow line joining at 
minimal convergence angle equal 
to 100º.

8.	Click Start.

9.	Most line segments are joined - they 
have become significantly longer. 
Probability of false recognition of 
defects at filtering has diminished. 
 
Fulfil the second line filtering with 
stricter parameters. In our example 
they are saved as Step_2 strategy of 
filtering.

10.	Click Preview to estimate quality 
of correction. Specify better 
parameters of defect selection if 
necessary and click Apply.

11.	Repeat item 11 several times in a 
row, until the number of defects of 
any type becomes zero.
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1.	Fulfil final breakup joining with a 
big search radius and without any 
limitation of convergence angle. 
The object is to delete long gaps 
and assemble «rubbish» into large 
objects. 

2.	Make the radius of continuation 
search equal to 50 pixels at a 
negative convergence angle -20º.

3.	Click Start.

4.	Correct the form of road lines at 
crossings. 
Select Auto Tracing -> Raw Line 
Filtering in Utilities menu.

5.	Apply Step_3 strategy. It corrects 
only defects of «T-joints» type.

6.	Click Preview to estimate quality of 
correction. Improve parameters of 
defect selection if necessary. 

7.	Click Apply.

Correct remaining defects manually. Don't forget to use Inspector tool for regular check 
of the project field.

Deletion of vector «rubbish» and gross distortions of object shape should be done by 
Vector Eraser tool   (Q hot-key). 

Simply erase spikes in lines, use «Red Eraser» (Shift key pressed) for deletion of irrelevant 
objects, and «Blue Eraser» (Ctrl key pressed) to cut objects up

Correct gross distortions of object shape with Camber Editor  (hot-key 3).

Apply Entity Editor  (hot-key ~) in the Join Polylines mode (hot-key E) to repair gaps 
in lines. Joining will be arcwise if you keep Shift pressed when indicating the segment to 
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1.	Select Topology -> Topology 
Correction in Utilities menu.

2.	Select Roads-to-frame strategy of 
topology correction. 
 
The object is to pulls road lines to 
the map frame, i.e. ends of lines 
from the Auto_lines layer to the 
frame from the Frame layer. 
 
Strategy parameters may be altered 
after you have clicked its name.

3.	Click Apply.

4.	Close the dialog box.

5.	Review the near-frame zone and 
pull «hanging» lines' ends (if any) to 
the map frame 
Use F (next)/V(previous) hot-keys 
to move from one correction site to 
another. 

be sewn; otherwise it will be linear.

AVOID UNNECESSARY WORK!

Delete only SERIOUS defects. Small spikes and superfluous vertices will be deleted by 
Line Form Optimization utility.

It may be reasonable to make a copy of the vector layer, to treat it with Line Form 
Optimization utility, and then to compare vector lines of both layers to understand, 
WHAT KIND OF DEFECTS should be corrected manually. 
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1.	Select Auto Tracing -> Line Form 
Optimization in Utilities menu.

2.	Use Roads set of parameters 
(strategy) or just specify their values 
shown in the figure.

3.	Click Start.

4.	Estimate optimization quality 
 
Apply Undo if necessary, improve 
parameter values, and run the 
utility once more.

Only now we may get rid of superfluous vertices in «dense» lines. Effectiveness of Vector 
Eraser and exactness of line end pulling to frame will be far lower if you do it earlier. 

It is easy to «brush off» a jut in a dense line with one stroke of Eraser, and Line Form 
Optimization utility will do the rest. But correction after optimization consists in transfer 
of individual vertices. It is MUCH LONGER... 

To make lines smoother, increase filter length but do not overdo it - too long filter can cut 
off sharp turns of lines.

Density of vertices in lines and therefor exactness of raster line tracing depend on 
Approximation. Big value means small number of points and rough approximation.

ATTENTION! The utility should be applied ONLY ONCE. Repeated data processing 
with the utility causes gradual straightening of vector lines and their offset from raster 
ones.
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1.	Check structure of the road 
network. Select Topology -> 
Topology Check-Up in Utilities 
menu.

2.	Select check-up strategy Road 
Network or specify parameters as 
shown in the figure.

3.	Click Start. After check completion, 
the program opens a window with 
information about revealed errors.

4.	Close the window. 

5.	The working window shifts 
automatically to the first found 
error and the error mark becomes 
current.  
Delete the mark with Del key - the 
object it concerned to becomes 
current (selected).

6.	Use F (next)/V(previous) hot-keys to 
move from one error to another.

7.	When all errors are corrected, 
repeat items 1 - 7 until you see the 
message «No errors found». 

Attribute data input, road linking to other objects and other operations remained 
outside the example. But hopefully you have already grasped basic principles of 
automatic vectorizing. 

Don't be afraid to experiment with utilities - they work fast, and Undo button is ready to 
cancel an unsuccessful result. 


